"no HX3 USB extension found" error

Rund um die "Clonewheels" HX3.1 bis HX3.4 (mk4) und HOAX 2

Moderator: happyfreddy

Beiträge: 8
Registriert: 14. Jan 2019, 06:05

"no HX3 USB extension found" error

Beitrag von jon54 » 10. Jan 2022, 01:47

Can someone point me to a location for downloading the Win 10 USB driver for my HX3 Expander module ver 4.25?

The module has been connected to my computer without problems for several days, then overnight I now get the msg "... no HX3 USB extension found" when attempting to open the unit in the HX3.4 Remote software. Everything is connected as it was the previous day when all was working. I figure my computer has 'lost track' of the USB driver.

I do have the file "FTDI driver CDM v2.08.30.exe" . An oline search said that it had something to do with drivers so I ran the exe file and a message said that some drivers had been installed. But after restarting the computer, the HX3 and the Remote software I still get the same "... no USB extension found" message from Remote.

Also as before, if I remove and reconnect the USB cable Win 10 says the USB device is not recognised. I have tried a different cable and USB port on the computer with the same results.

Beiträge: 139
Registriert: 14. Nov 2015, 13:46

Re: "no HX3 USB extension found" error

Beitrag von Christian » 12. Jan 2022, 16:51

Just so the question doesn't go unanswered, here's a quote from the thread opener from the Facebook HX3 Organ Users group:

Weirdly the issue has resolved itself. Maybe it was the order of events; boot up computer... power up HX3... connect USB cable... ding-dong! Windows recognises the HX3 🙂


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast