Preset 12-2

Rund um die "Clonewheels" HX3.1 bis HX3.4 (mk4) und HOAX 2

Moderator: happyfreddy

alexederer
Beiträge: 7
Registriert: 30. Dez 2017, 09:36
Kontaktdaten:

Preset 12-2

Beitrag von alexederer » 6. Aug 2021, 09:23

Hallo,
Ich habe hier ein kleines Problem.
Die Orgel ist 2- Manualig nach B3 Vorbild aufgebaut. Board ist HX3 mk4. FIrmware 4.25 FPGA 25042017.
Pro Manual 2 Hammond - Zugriegelsätze.
Verbaut wurde die Preset12-2 Platine mit inversen Tasten.
Die Umschaltung erfolgt über die in diesem Forum vorgestellte 2 x aufgebaute Schaltung mit 4053er über Pin 15.
Parameter 483 wurde auf 1 gesetzt.
Obermanual funktioniert einwandfrei. Live 1 u. 2 über a# / H.
Beim Untermanual funktioniert es nicht. Bei Einstellung Live egal ob 1 oder 2 ertönt die 5 1/3 Fußlage. Dazuschalten kann ich 1 1/3 und 1.
Die übrigen Zugriegel haben keinen Einfluss.
Ich bereits bei der Preset und der Umschaltplatine die Anschlüsse gewechselt aber das Ergebnis ist dasselbe.
Die Preset´s selbst funktionieren ebenso die Programmierung.
Muss hier vielleicht noch ein Parameter geändert werden?

Besten Dank und Gruß
Alex

happyfreddy
Beiträge: 1941
Registriert: 19. Jul 2012, 09:32
Kontaktdaten:

Re: Preset 12-2

Beitrag von happyfreddy » 6. Aug 2021, 10:29

ES wurde schon an diversen Stellen im Forum über dieses Thema gesprochen

viewtopic.php?f=3&t=467
viewtopic.php?f=3&t=544

Wenn es auf zwei einzelnen Platinen aufgebaut ist können die untereinander getauscht werden.
DFabi muß nur der Jumper für OM - UM entsprechend gesetzt sein.
Beide Platinen werden am Plug 4 des Mainboards angeschlossen. Das ist der gleiche
Plug an dem auch das Display sitzt
Auf der kombinierten Platine die ich seinerzeit mal entworfen habe ist ein weiterer Plug vorhanden
um dort das Display anzuschließen

Die Schaltung meiner Platine entspricht der Originalplatine Preset 12.
Lediglich die Pinbelegung für die LEDs habe ich geändert wegen dem Layout für die LED Streifen.

Wichtig bei diesen Presetplatinen und dem Mainboard ist jedoch daß der Pin 15 bei den Zugiegeln frei ist.
Neuere Boards nutzen diesen als Umschaltpin für die neuen Zugriegelplatinen auf denen ja die Umschalt ICs
74HC4053 sitzen. Diese werden mit der Spannung an den Zugriegeln mit 3,3V betrieben.
Die separaten Platinen mitz den 4053 jedoch werden an 5 Volt betrieben.
Genau deswegen darf der Pin 15 mnicht mit Pin 16 bei den Zugriegeln verbunden sein

Wenn hier nur einzelnen Fußlagen erklingen bei der zweiten Platine liegt hier ein Fehler in der
Verdrahtung vor bzw defekte Umschalt IC 4053.
Hier würde ich die IC der Platine die nicht funktioniert einzeln bei der funktioniernden Platine
des OM mal testen, Jeder IC beinhaltet 3 Umschalter die drei Umschaltleitungen an Pin 9,10,11 werden
gemeinsam geschaltet

alexederer
Beiträge: 7
Registriert: 30. Dez 2017, 09:36
Kontaktdaten:

Re: Preset 12-2

Beitrag von alexederer » 6. Aug 2021, 16:32

Hallo,
Danke für die schnelle Antwort.
Ich habe 2 Platinen aus dem Beitrag vom 18.05.2016.
Wie gesagt funktioniert die Umschaltung mit Pin 15 beim OM einwandfrei. Auch wenn ich die Platinen tausche funktioniert das OM fehlerfrei.
Beim UM dagegen hat Pin 15 konstant High-Pegel.
Ich denke ich werde die Umschaltung nach dem Schema von Drawbar MPX 2.0 realisieren.

Besten Dank und Gruß
Alex
Dateianhänge
Screenshot 2016-05-18 19.57.47.png
(60.75 KiB) 194-mal heruntergeladen

happyfreddy
Beiträge: 1941
Registriert: 19. Jul 2012, 09:32
Kontaktdaten:

Re: Preset 12-2

Beitrag von happyfreddy » 6. Aug 2021, 17:42

Hi

Denke da ist der Pin 15 auf dem HX 3 Board Plug UM noch mit 5 V vom Pin 16 via Flachkabel verbunden.
Die Leiterplatte wurde ja entworfen als der Pin 15 generell mit Pin 16 verbunden war.
Isolier also am abgehenden Plug des Preset Boards zum HX 3 Board den Pin 15 :
Am HX Mainboard KEINE VERÄNDERUNGEN vornehmen !!!!
Alles was man ändert auf den Preset Boards
Leiterbahnen zwischen Pin 15 und 16 und zum Pin 16auf der Preset Platine auftrennen.
Dann ist es egal ob am Mainboard die Pins 15 und 16 noch verbunden sind oder nicht.
Ist die Leitung Pin 15 am Presetboard isoliert ist es das gleiche wie wenn dies am Mainboard so wäre.

alexederer
Beiträge: 7
Registriert: 30. Dez 2017, 09:36
Kontaktdaten:

Re: Preset 12-2

Beitrag von alexederer » 8. Aug 2021, 09:23

Hallo,
Der "Fehler" ist behoben. Ist zwar nicht die Verbindung 15/16 aber dank Deines Tip´s hab ich ein neues Kabel gefertigt
und es lief einwandfrei. Beimk Alten Kabel war der Pfostenstecker verkehrt montiert :mrgreen:

Besten Dank und Gruß
Alex

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste