Firmware Update misslungen

Rund um den Hammond-Clone HOAX3

Moderator: happyfreddy

Volker Grosch

Firmware Update misslungen

Beitragvon Volker Grosch » 10. Dez 2016, 14:05

Hallo liebe Community,

ich stelle mich einmal kurz vor: ich bin seit Anfang Juli dieses Jahres stolzer und sehr zufriedener Besitzer des HX3 plexi Expanders. Anders als vermutlich die meisten hier bin ich eher Hobbykeyboarder als "echter" Organist und habe die HX3 in ein an sonsten nur aus VSTs bestehendes PC setup eingebunden in dem er eine ausgezeichnete Figur abgibt. Dabei nutze ich die MIDI Ccs zur Steuerung aller Parameter aus der Software heraus, so dass alle Sounds in der PC software gespeichert werden können. Für den direkte Zugriff auf der Bühne ist ein V4D eingebunden. Genug der Vorstellung und zu meinem eigentlichen Anliegen:

Da ich mitbekommen habe, dass die Firmware der HX3 mittlerweile einige Updates erhalten hat und die Resonanz der user hier sehr positiv war (insbesondere die Vibratos sollen ja noch einmal einen tüchtigen Schub bekommen haben), habe ich mich heute zu einem Update entschlossen. Leider scheint hier etwas schief zu gegen. Beben der Tatsache, dass die ursprüngliche Parametrierung der HX3 komplett verändert war, klingen die Vibratos (V1...V3) extrem merkwürdig (das kann man am ehesten mit einem "Klacken" als mit einer Modulation bezeichnen und hat sicher nichts mit dem eigentlich gewollten Vibrato zu tun.

Ich hab das Update daher mehrfach wiederholt (ebenso das zip-file mehrmals heruntergeladen), aber keine Veränderung bekommen.

Dabei sind 2 Dinge auffällig:
1) Nach dem Fireareupdate wird der Expander nicht automatisch durchgestartet, das muss ich von Hand erldugen, der Rest läuft dann reibungsfrei ab.

Es gibt bezüglich des AVR offenbar sync errors (die mir anfangs nicht aufgefallen sind). Das Protokoll hönge ich mal unten an (serials hab ich ausge-x-t).

Verwedet habe ich das plexi file mit dem updte mk3/mk4, da der Expabder erst im Juli 2016 geliefert wurde, nicht referbished war, so dass ich davon ausgehe, dass jein mk2 Board enthalten ist.

Ich habe im Übrigen auch verschiedene USB ports, verschiedene USB-Kabel versucht und das Laptop auch einmal ohne Netzteil ausschließlich mit dem HX3 und dessen Netzteil (keine Audio- oder MIDI-Kabel) verbunden, um Masseschleifen als Ursache sicher auszuschließen.

Nun bin ich ein bisschen ratlos, was ich noch versuchen könnte. Kann mir vielleicht jemand auf die Sprünge helfen?

Vielen Dank schon mal und liebe Grüße, Volker




Connected to FT232R USB UART on COM3

Connection to HX3 established.

Licence info written to hx3_licence_237647.txt

Customer Name: Volker Grosch
Serial Number: 237647
Licence Organ: xxxxxxxx Rotary: xxxxxxx
Firmware Version: MIDI Expander #3.925
FPGA Version: #26102016
Scan Version: MIDI input #30

Hint: You may change User Name or Licence Number(s)
and click red "Set Licence" or "Set User Name" Button.

Licence info written to hx3_licence_237647.txt
Read organ data...
Read preset data...
Read MIDI CC data...

Flash file: H:\neues Laptop\Musikequipment\HX3\Flash_Expander_mk3_4\HX3mk3_expander.hex
EEPROM file: H:\neues Laptop\Musikequipment\HX3\Flash_Expander_mk3_4\HX3mk3_expander.eep
Update takes approx. 2 minutes.
avrdude.exe: stk500_recv(): programmer is not responding
avrdude.exe: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude.exe: stk500_recv(): programmer is not responding
avrdude.exe: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude.exe: stk500_recv(): programmer is not responding
avrdude.exe: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude.exe: stk500_recv(): programmer is not responding
avrdude.exe: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude.exe: stk500_recv(): programmer is not responding
avrdude.exe: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude.exe: stk500_recv(): programmer is not responding
avrdude.exe: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude.exe: stk500_recv(): programmer is not responding
avrdude.exe: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude.exe: stk500_recv(): programmer is not responding
avrdude.exe: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude.exe: stk500_recv(): programmer is not responding
avrdude.exe: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude.exe: stk500_recv(): programmer is not responding
avrdude.exe: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

avrdude.exe done. Thank you.


Waiting for HX3 firmware boot...
Connected to FT232R USB UART on COM3
##### Error: No response or process timed out
Restore preset data...
Restore MIDI CC data...

Restore licences from hx3_licence_237647.txt
FPGA configuration date: 26102016
FPGA update skipped, was up to date.
Updating file HX_MIDI.DAT
Packets sent: 32
Updating file dsp_rev.bin
Packets sent: 32
Updating file taper_levels1.dat
Packets sent: 32
Updating file taper_levels2.dat
Packets sent: 32
Updating file taper_levels3.dat
Packets sent: 32
Updating file taper_levels4.dat
Packets sent: 32
Updating file fir_coeff.dat
Packets sent: 16
Updating Parameters...
433=0 [restored] #0:255=0 [OK]

438=1 [updated] #0:255=0 [OK]

439=18 [updated] #0:255=0 [OK]

477=1 [updated] #0:255=0 [OK]

492=0 [updated] #0:255=0 [OK]

481=0 [updated] #0:255=0 [OK]

478=255 [updated] #0:255=0 [OK]

485=255 [updated] #0:255=0 [OK]

607=150 [updated] #0:255=0 [OK]

Current configuration saved to Factory Defaults

Customer Name: Volker Grosch
Serial Number: 237647
Licence Organ: xxxxxxxx Rotary: xxxxxx
Firmware Version: MIDI Expander #3.925
FPGA Version: #26102016
Scan Version: MIDI input #30

Volker Grosch

Re: Firmware Update misslungen

Beitragvon Volker Grosch » 11. Mai 2017, 08:56

Hallo,

wollte nur eben Entwarnung geben: offenbar hab ich mir ein falsches zip file gezogen. Mit dem letzten lief der Updatevorgang reibungslos durch auf FW4.2.1. Settings muss ich zwar neu einstellen aber Scanner arbeitet nun einwandfrei.

Die neuen Vibratos klingen für meine Ohren nocheinmal wesentlich besser als zuvor. Daher: alles gut und sorry für den Wirbel.

LG, Volker


Zuletzt als neu markiert von Anonymous am 11. Mai 2017, 08:56.


Zurück zu „HOAX3 Discussion“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast